ISP Carrier Service Disruption
Incident Report for Rescue and GoToAssist
Resolved
We are no longer receiving reports of connectivity issues and affected ISP's appear to be stable.
Posted 5 months ago. Jul 02, 2018 - 14:41 UTC
Update
We continue to see stabilization with ISP providers, but will continue to monitor through the weekend.
Posted 5 months ago. Jun 29, 2018 - 22:38 UTC
Monitoring
We have reports of some ISP's coming back online and will continue to monitor the situation.
Posted 5 months ago. Jun 29, 2018 - 19:08 UTC
Investigating
Some customers are currently being impacted by ISP outages across North America. These outages may be impacting customer's ability to use our services. Please contact your ISP if you continue to experience issues. We are currently working to identify and resolve any issues with our local ISP, and will update this page with any new information
Posted 5 months ago. Jun 29, 2018 - 17:59 UTC
This incident affected: Rescue, GoToAssist Remote Support, GoToAssist Service Desk, GoToAssist Corporate, and GoToAssist SeeIt.