GoToAssist Service Desk Email Delay - Issue Identified
Incident Report for Rescue and GoToAssist
Resolved
This issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Apr 23, 2018 - 18:16 UTC
Identified
We have identified an issue with GoToAssist Service Desk where some customers are experiencing a delay in receiving their email notifications. We have engaged our on-call responders and are working to resolve this as soon as possible.

We are sorry for any inconvenience this may cause.
Posted Apr 23, 2018 - 15:10 UTC
This incident affected: GoToAssist Service Desk.