GoToAssist SeeIt - Unable to access the website, start or join new sessions
Incident Report for Rescue and GoToAssist
Resolved
Our engineers have worked on fixing the application, The application is up and running but in a degraded capacity. Customers might experience issues while generating the PIN.

Investigations will be continued by our Engineers to fix this issue permanently.
Posted Sep 24, 2021 - 16:38 UTC
Update
Our engineers are actively working towards a resolution for this issue. We will provide another update as soon as it is available.
Posted Sep 24, 2021 - 13:00 UTC
Update
Our engineers continue to work actively on a fix for this issue. We will provide another update as soon as it is available.
Posted Sep 24, 2021 - 04:28 UTC
Update
Our engineers are continuing to work on a fix for this issue.

We will provide another update shortly.
Posted Sep 24, 2021 - 00:33 UTC
Identified
Our engineers believe to have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Sep 23, 2021 - 19:54 UTC
Update
We are continuing to investigate this issue.
Posted Sep 23, 2021 - 19:53 UTC
Update
We are actively investigating reports that GoToAssist SeeIt customers may be experiencing a blank page while accessing the website(https://seeit.gotoassist.com), also, customers are unable to join or start new sessions.
Posted Sep 23, 2021 - 19:39 UTC
Investigating
We are actively investigating reports that GoToAssist SeeIt customers may be experiencing a blank page while accessing the website(https://seeit.gotoassist.com).

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Sep 23, 2021 - 19:30 UTC
This incident affected: GoToAssist SeeIt.