Rescue, RescueAssist, GoToAssist Remote Support, GoToAssist Service Desk, GoToAssist Corporate, GoToAssist Seeit - Customer Care is Unavailable
Incident Report for Rescue and GoToAssist
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Oct 24, 2019 - 02:32 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted Oct 24, 2019 - 02:18 UTC
Update
Our engineers are still working to restore power.

We will provide further updates once more information becomes available.
Posted Oct 23, 2019 - 23:46 UTC
Identified
Our engineers have identified a power outage in our call center due to inclement weather.

We will provide another update shortly.
Posted Oct 23, 2019 - 22:28 UTC
This incident affected: Rescue, RescueAssist, GoToAssist Remote Support, GoToAssist Service Desk, GoToAssist Corporate, and GoToAssist SeeIt.