RescueAssist, GoToAssist Remote Support, GoToAssist Service Desk & GoToAssist SeeIt - Unable to sign up for trial or purchase
Incident Report for Rescue and GoToAssist
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Nov 13, 2019 - 14:43 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted Nov 13, 2019 - 14:38 UTC
Identified
Our engineers believe to have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Nov 13, 2019 - 14:32 UTC
Investigating
We are actively investigating reports that some RescueAssist, GoToAssist Remote Support, GoToAssist Service Desk and GoToAssist SeeIt customers may be experiencing issues while trying to Sign up or purchase.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Nov 13, 2019 - 14:32 UTC
This incident affected: RescueAssist, GoToAssist Remote Support, GoToAssist Service Desk, and GoToAssist SeeIt.