GoToAssist Remote Support - Errors when inviting external technicians
Incident Report for Rescue and GoToAssist
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted Jan 25, 2020 - 00:12 UTC
Identified
Our engineers believe to have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.

In the meantime: A workaround has been found. Using the support key rather than the link will allow external technicians to join successfully.

Thank you for your patience and understanding
Posted Jan 24, 2020 - 22:58 UTC
Investigating
We are actively investigating reports that some GoToAssist Remote Support customers may be experiencing issues with inviting external technicians.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted Jan 24, 2020 - 22:50 UTC
This incident affected: GoToAssist Remote Support.